We are currently experiencing a problem with our service
Incident Report for Soundtrack Your Brand
Resolved
All affected players should now be playing normally again
Posted Feb 16, 2024 - 13:17 UTC
Update
We have started a rollback of all players to a known good version
Posted Feb 16, 2024 - 11:19 UTC
Update
Some customers experience interrupted playback
Posted Feb 16, 2024 - 10:30 UTC
Update
We are continuing to investigate this issue.
Posted Feb 16, 2024 - 10:28 UTC
Investigating
Some customers experience interrupted playback
Posted Feb 16, 2024 - 10:21 UTC
This incident affected: Music Management and Music Playback.