api-down
Incident Report for Soundtrack Your Brand
Resolved
The issue is now resolved and everything should be back to normal.
Posted Mar 15, 2023 - 15:34 UTC
Investigating
Users might have problem navigating in the app. We are currently investigating this issue.
Posted Mar 15, 2023 - 15:26 UTC