Music downloads
Incident Report for Soundtrack Your Brand
Resolved
This incident has been resolved.
Posted Feb 10, 2020 - 15:59 UTC
Update
Update: Our provider is still troubleshooting the issue with our assistance.
Posted Feb 07, 2020 - 19:52 UTC
Investigating
A smaller number of accounts in North America have difficulty downloading music. Our network provider is currently investigating the issue.
Posted Feb 07, 2020 - 16:21 UTC
This incident affected: Music, account management & payments.