Increased Error Rates
Incident Report for Soundtrack Your Brand
Resolved
Our players experienced some issues downloading and playing new tracks for a brief period. This problem has been resolved, and everything should now be back to normal.

Just let us know if you are still experiencing any issues.
Posted Oct 05, 2023 - 10:08 UTC
Investigating
We are currently investigating this issue.
Posted Oct 05, 2023 - 09:41 UTC