Intermittent navigation or playback issues
Incident Report for Soundtrack Your Brand
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 08:30 UTC
Monitoring
Our service should not be affected anymore. Still monitoring for any further issues.
Posted Jun 21, 2022 - 07:34 UTC
Investigating
Our third party service Cloudflare are experiencing some problems, which seems to have some intermittent issues on navigation and playback. We are currently working on investigating the issue.

Cloudflare status page: https://www.cloudflarestatus.com/
Posted Jun 21, 2022 - 07:15 UTC
This incident affected: Account Management, Payments, and Music Management.