Remote app fails to load locations
Incident Report for Soundtrack Your Brand
Resolved
We found the issue and the incident has been resolved.
Posted Feb 04, 2022 - 11:09 UTC
Investigating
We are currently having problems with the remote app not being able to load location list. We are currently investigating this.

Temporary workaround: Please use the web to control your locations.
Posted Feb 04, 2022 - 10:50 UTC
This incident affected: Players & apps (Soundtrack Remote).